Posted in , | 70 Responses
Sandip Dedhia

Sandip Dedhia

Sandip Dedhia is the founder of, he loves to write on technology, gadgets & web services. At Blogsdna you can read his Windows tutorials, free and useful software related articles. He is on twitter too @sandipnd View author profile

70 Responses to Fix Windows 7 Sidebar & Gadgets Not Working When UAC is Disabled

  • Joe Young says:

    Thank you for this fix my friend, great instructions. I am using Win 7 64 bit with 8GB of ram and love it, so much better than Vista already and blazing fast. I have not experienced any issues at all except for this sidebar thing. It will be another mistake if they disable the sidebar when disabling UAC. I hate the UAC but am sure it will be useful to some. Thanks again!

  • Nikita says:

    Thank U from Russia! :)

  • Beerbellybilly says:

    Thx for help even thoug i am drunk, very helpfull. Buuuurp

  • SmoakThatBowl says:

    Thank you very much, works like a charm!

    I’m in agreement with many others, so far I’m enjoying W7 more than Vista and I’ve been using V for quite sometime. The easy accessibility of the wireless networks and option of adding admin rights to temporary tasks is a major upgrade.

    UAC removal took me a second to figure out, but once that was over, it’s been a great experience so far.

  • Troy says:

    Thanks!! That was driving me nuts trying to figure out how to get those things back on!!

  • Mictain says:

    Now if I can just figure out how to get 32 bit flash gadgets to work. I love the weather addon called “Pro Weather”, but can’t get it to work in Windows 7. :(

  • Stef says:

    Thanks a lot! You saved a lot of my nerves :-)))

  • Ahish says:

    thank u!!!

  • Alex Jorge says:

    Thanks for this.

    I Download the utilities and save this page, First thing to do when I arrive home is try it.


  • Mictain says:

    Now if I can just figure out how to get 32 bit flash gadgets to work. I love the weather addon called “Pro Weather”, but can’t get it to work in Windows 7. :(

    Forgot to mention…I’m running 64 bit Windows 7

  • Jubran says:

    its work 100%

    big thanks

  • itchan says:

    working and simple tutorial. nice dude

  • Cap'n Jack Burntbeard says:

    Thanks you rock

  • Britney says:

    WOW, thank you SO MUCH for this!!!!!!!!!! 100% satisfied with this solution! I’ve been so mad at it not working, and now it does. Do you think you could fix my tuner card that doesn’t work now? (it worked for a week or so then decided to not work).

    Thanks again!

  • .c says:

    worked perfectly on win 7 beta via boot camp on osx leopard.


  • Blake Woodington says:

    Thank’s a heap mate, i thought my beta was rooted. Thanks for the solution!

  • N1C3 says:

    Thanks so much, it is very appreciated i do a lot of OC’ing and my desktop gadgets help me keep on eye on my CPU vitals :D

    Best tutorial I have ever seen :D

  • Nick says:

    Nice work around, this exactly what I needed. Thanks!

  • darshan says:

    thanks it worked……..

  • nurul says:

    nice tutorial, is it ok if i post this article to mine for my archive?

  • Fabiano Brazil says:

    Thank you!Yes I got it
    You’re the best!!!

  • Ran says:

    good work…
    Thanks.. Worked fine

  • Saman says:

    tnx sooooooooooooooooooooooooooooooooooooo much:X:X:X:X:X:*:*:*:*:*:*:*

  • kurt80 says:

    you are a goddess

  • gautham says:

    your explanation is stupid.

    i am also using win 7 with uac disabled. but it works fine. maybe some problem with ur build

  • Britney says:

    Is there anyway to make the “sidebar” not run on startup… msconfig doesn’t give me any option and the program itself doesn’t either. Thanks in advance…

  • Yannis says:

    Thanx from Greece

  • Thank’s a heap mate, i thought my beta was rooted.

  • Kanerd6 says:

    i followed this, but i didn’t find settings in the sidebar folder. under it was just another folder for compatibility. please help!!

  • Asifkhan_619 says:

    Try in : HKEY_CURRENT_USERSOFTWAREMicrosoftWindowsCurrentVersionSidebarSettings

  • Yarkov Anton says:

    Guys, I made a small simple gadget for text editing. You can download and try the installation for it on my website (of course, for free):
    Please, write me your ideas and suggestions about creating of gadgets or software you need =).

  • Badjek606 says:

    Try this one, It may work! Ive done all that stuff but it doesn’t solve the problem. Downlaod Malwarebyte here is the link: (free download) install>Full scan> removed selected. Mine was not displaying properly like that in the above but this solve my problem! Good luck!

  • Tom says:

    Guys, I went to HKEY_CURRENT_USERSOFTWAREMicrosoftWindowsCurrentVersionSidebarSettings but there was no settings folder???? Can anyone please help me? Where to from here? Thanks in advance. :)

  • Suchibrata Ash says:

    did not have a satisfied result……………..

  • Simranrocks94 says:

    Just close all the gadgets from desktop and then try it out,
    If not then do these fuking things!!!!

  • Paleozoid says:

    Hi Tom,

    Did you get an answer to this question? I have exactly the same problem.


  • I am also using win 7 with uac disabled.

  • Marvin1317 says:

    This worked perfectly, great freeware.. thx
    (I did’t have settings under sidebar also..)

  • Tom says:

    Problem Solved.. Your side bar will work perfectly when you create a new user and delete your old one… but before you delete your old one find out how to transfer all your files to your new user….. :)

  • Hefkam says:

    Worked fine for me. Thx.

  • Manolo says:

    funcciona! Gracias!

  • Hi says:

    Ok the sidebar works it’s just when I put gadgets on the sidebar its like they are corrupted or something because all the gadgets are messed up. They just show like maybe the outline or maybe just some dots that are on the gadget.

  • Hi says:

    never mind it’s working now thanks to that program.

  • Rajram2 says:


  • Rajram2 says:

    please tell me i cannot find the folder setting hoe to create

  • rammayor says:

    i had a similar kind of problem on my windows 7 64 bit version. Some gadgets disappeared and the clock turned black. After a long time found a solution.

    Deleting the Zone setting from Registry can help fix the Gadgets issue.

    1. Open regedit and navigate to the following key: HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionInternet Settings Here, delete the Zones Key

    2. Restart the Computer and test it

    it worked for me..check it out guys and let me know!!

  • Prithvi Ice says:

    Tns rammya love u uuuuuuuuuuuuuuuummmmmmmmmmmmmmmmmaaaaaaaaaaaaaaaa

  • Razara says:

    hey, thanks for the solution with installing and scanning with malwarebytes..! it’s work for me very well…and i’m happy now. =)

    i’m very appreciate it and thanks again, Badjek606 .

  • Biswas0002 says:

    i m not getting zonekeys……………………………….

  • orange.. says:

    i also followed thos, but i didn’t find settings in the sidebar folder….
    plz reply..

  • Trex says:

    Thanks a lot! it worked for me as well.

  • Felipe_fsa says:

    Thanks a lot!!!
    I’ve got my problem, which was the same, completely solved.
    I even had other bug envolving ActiveX solved after the scan.
    Pretty efficient solution!!

  • Nick says:

    thank you man , it realy helped me , i’ve tried all this stuff with removing the zones registry folder and many other and thought that nothing will help me.
    this malware also has found other issues and fixed them.

    thanks a lot from Moldova.

  • AJ says:

    Mine use to work and now it doesn’t. I haven’t changed any settings however I tried to do what it says here but “Settings” doesn’t exist in my “sidebar” folder it only has “compatibility” written there.

  • Admin says:

    You saved my day! :) Many thanks from Poland.

  • solved all of my Win7 (64bit) gadget problems!!!!!!

    Badjek606 U R THE MAN!!! THE MAAAAN!!!

    Best regards!

  • Mesha says:

    I’m using windows 7 32bit, I’ve followed the instruction above, but my gadget still doesn’t work.. :(
    could someone please help me ?

  • Ezra_drummer13 says:

    gadgestku iki rah kenek mas…
    mestii metuu gadgets stoped mas..
    yok op cara mas???
    pean lak iso emailen aq yoo…
    swun sak durunge..

  • antuk says:

    There is another “workaround” for those gadgets not functioning on Win 7. Try this, it worked for me when all the other solutions failed:L
    There is a very easy solution for this problem:
    1. open the regedit
    2. navigate to this address:
    HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionInternet SettingsZones
    3. Rt. click on Zones and export it to your desktop as a backup.
    4. Delete Zones and re-start your computer.
    5. You should be able now to display your gadgets.

  • Isamo4u says:

    thank u alot from japan^^

  • elcapo says:

    The zones’ trick did work for me, thanks a lot antuk!

  • Starkey says:

    Thanks very much works on the first time :X

  • Keith says:

    …..ive tried many ways to fix it.. grrr, ,anyway , ,thank you for sharing that link solved my problem .^_^ @ rednash

  • Keith says:

    …..ive tried many ways to fix it.. grrr, ,anyway , ,thank you for sharing that link solved my problem .^_^ @ rednash